Connecting the world…

trunk

802.1Q between Catalyst 3750 en PowerConnect 6226

Configuring a 802.1Q connection isn’t that difficult, but you need to know the command line interface and the appropriate commands. Today I configured a 802.1Q connection between a Cisco Catalyst 3750G and a Dell PowerConnect 6226, while configuring I played a little with the trunking options on the PowerConnect and I noticed the following:

  • The Dell PowerConnect 6226 doesn’t support the configuration of a native vlan in switchport mode trunk

To solve this problem you should use the switchport mode general commands. I configured the 802.1Q connection on the Dell PowerConnect 6226 with the following commands:

interface ethernet 1/g24
description ‘802.1Q C3750G’
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan remove 1
switchport general allowed vlan add 10 untagged
switchport general allowed vlan add 255 tagged
switchport general allowed vlan add 1128 tagged
switchport general allowed vlan add 1129 tagged
exit

The command no switchport general acceptable-frame-type tagged-only prevents the switch from discarding untagged frames at ingress. I configured the Cisco Catalyst 3750 with the following commands:

interface GigabitEthernet1/0/4
description 802.1Q DELL POWERCONNECT 6226
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,255,1128,1129
switchport mode trunk
switchport nonegotiate
no ip address
no mdix auto
end

The above configuration is working perfectly. Packets from VLAN 10 are sent untagged over the link and all other VLAN’s are sent tagged over the link. I guess it would be easier if the switch supported the configuration of a native VLAN in trunking mode.

What is an UPLINK port?

A colleague recently encountered some problems with keepalives on switch ports. He wrote a post about it. Keepalives are, quoted from his blog post:

By default Cisco routers and switches periodically test their (Fast) Ethernet links by sending out Loopback frames (ethertype 0×9000) addressed to themselves. Call it a “L2 self-ping” if you will. In a switched environment it can be used to test the functionality of the switch and/or keep the router’s MAC address in the switch’s address table. Another thing what this Loopback frames do, is to check for a loop. If there is a loop in the network, the resulting Loopback frame will be seen by the sending switch and the port will be err-disabled.

Cisco says that starting in 12.2SE based releases, keepalives are NO longer sent by default on fiber and uplink interfaces.

The big question, where I am struggling with is:

When is a port an UPLINK port?

Looking at a Cisco Catalyst 2960-24PC-L I get the following information about the keepalives information on the interfaces.

SW01#sh int | i 0/23|0/24|GigabitE|Keep

FastEthernet0/23 is down, line protocol is down (notconnect)
  Keepalive set (10 sec)
FastEthernet0/24 is down, line protocol is down (notconnect)
  Keepalive set (10 sec)
GigabitEthernet0/1 is up, line protocol is up (connected)
  Keepalive not set
GigabitEthernet0/2 is up, line protocol is up (connected)
  Keepalive not set

The output above shows that keepalives are enabled on the FastEthernet connections by default and disabled on the GigabitEthernet connections. The GigabitEthernet connections are dual-purpose, but I don’t use the fiber connection. But because it is a dual-purpose port I can imagine that keepalives are disabled by default, because of the fiber properties.

So I looked at at Cisco Catalyst 2960-48TT-L switch with Software Version 12.2(44)SE. This switch doesn’t have any fiber connections, but only copper. From this switch I get the following keepalives information.

SW01#sh int | i 0/47|0/48|GigabitE|Keepa

FastEthernet0/47 is down, line protocol is down (notconnect)
  Keepalive set (10 sec)
FastEthernet0/48 is down, line protocol is down (notconnect)
  Keepalive set (10 sec)
GigabitEthernet0/1 is down, line protocol is down (notconnect)
  Keepalive set (10 sec)
GigabitEthernet0/2 is up, line protocol is up (connected)
  Keepalive set (10 sec)

The output tells me that keepalives are enabled on all switch ports. GigabitEthernet0/2 is configured as a trunk port, so now I am very confused.

I draw the following conclusions:

  1. Keepalives are disabled on uplink and fiber ports starting in 12.2SE releases. GigabitEthernet0/2 from the 48TT-L switch is configured as a trunk port. So a trunk port doesn’t mean the same as an uplink port;
  2. The “special” ports on the right side of a switch are no uplink ports, because else GigabitEthernet0/2 from the 48TT-L switch would have keepalives disabled;

After drawing these conclusion I still don’t know the exact definition of an UPLINK port :-(. Please let me know if you have any suitable definition for an UPLINK port………