Connecting the world…

switchport

802.1Q between Catalyst 3750 en PowerConnect 6226

Configuring a 802.1Q connection isn’t that difficult, but you need to know the command line interface and the appropriate commands. Today I configured a 802.1Q connection between a Cisco Catalyst 3750G and a Dell PowerConnect 6226, while configuring I played a little with the trunking options on the PowerConnect and I noticed the following:

  • The Dell PowerConnect 6226 doesn’t support the configuration of a native vlan in switchport mode trunk

To solve this problem you should use the switchport mode general commands. I configured the 802.1Q connection on the Dell PowerConnect 6226 with the following commands:

interface ethernet 1/g24
description ‘802.1Q C3750G’
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan remove 1
switchport general allowed vlan add 10 untagged
switchport general allowed vlan add 255 tagged
switchport general allowed vlan add 1128 tagged
switchport general allowed vlan add 1129 tagged
exit

The command no switchport general acceptable-frame-type tagged-only prevents the switch from discarding untagged frames at ingress. I configured the Cisco Catalyst 3750 with the following commands:

interface GigabitEthernet1/0/4
description 802.1Q DELL POWERCONNECT 6226
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,255,1128,1129
switchport mode trunk
switchport nonegotiate
no ip address
no mdix auto
end

The above configuration is working perfectly. Packets from VLAN 10 are sent untagged over the link and all other VLAN’s are sent tagged over the link. I guess it would be easier if the switch supported the configuration of a native VLAN in trunking mode.

Port-channel configuration for VMWare

I received some e-mails from people asking for configuration examples for Cisco switch in conjunction with VMWare servers. That is why I post the configuration (I normally use) beneath. This configuration enables a 802.1Q trunk connection between the switch and the VMWare server. This configuration requires the VMWare server to use VLAN tagging. The Port-channel consist two physical GigabitEthernet interfaces.

Configuration Example:

port-channel load-balancing src-dst-ip
!
interface Port-channel1
description 802.1Q to VMWare
switchport trunk encapsulation dot1q
switchport nonegotiate
switchport mode trunk
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/1
description Member Po1
switchport trunk encapsulation dot1q
switchport nonegotiate
switchport mode trunk
no cdp enable
channel-group 1 mode on
spanning-tree portfast trunk
!
interface GigabitEthernet2/0/1
description Member Po1
switchport trunk encapsulation dot1q
switchport nonegotiate
switchport mode trunk
no cdp enable
channel-group 1 mode on
spanning-tree portfast trunk

CDP is the Cisco propriatery Cisco Discovery Protocol. CDP can be usefull when trying to discover attached network components. VMWare supports CDP, so it could be enabled on the interfaces. The usage of CDP can help to see which switch port connects who which NIC on the ESX server.