Connecting the world…

Port-channel configuration for VMWare

I received some e-mails from people asking for configuration examples for Cisco switch in conjunction with VMWare servers. That is why I post the configuration (I normally use) beneath. This configuration enables a 802.1Q trunk connection between the switch and the VMWare server. This configuration requires the VMWare server to use VLAN tagging. The Port-channel consist two physical GigabitEthernet interfaces.

Configuration Example:

port-channel load-balancing src-dst-ip
!
interface Port-channel1
description 802.1Q to VMWare
switchport trunk encapsulation dot1q
switchport nonegotiate
switchport mode trunk
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/1
description Member Po1
switchport trunk encapsulation dot1q
switchport nonegotiate
switchport mode trunk
no cdp enable
channel-group 1 mode on
spanning-tree portfast trunk
!
interface GigabitEthernet2/0/1
description Member Po1
switchport trunk encapsulation dot1q
switchport nonegotiate
switchport mode trunk
no cdp enable
channel-group 1 mode on
spanning-tree portfast trunk

CDP is the Cisco propriatery Cisco Discovery Protocol. CDP can be usefull when trying to discover attached network components. VMWare supports CDP, so it could be enabled on the interfaces. The usage of CDP can help to see which switch port connects who which NIC on the ESX server.

The following two tabs change content below.

René Jorissen

Co-owner and Solution Specialist at 4IP Solutions
René Jorissen works as Solution Specialist for 4IP in the Netherlands. Network Infrastructures are the primary focus. René works with equipment of multiple vendors, like Cisco, Aruba Networks, FortiNet, HP Networking, Juniper Networks, RSA SecurID, AeroHive, Microsoft and many more. René is Aruba Certified Edge Expert (ACEX #26), Aruba Certified Mobility Expert (ACMX #438), Aruba Certified ClearPass Expert (ACCX #725), Aruba Certified Design Expert (ACDX #760), CCNP R&S, FCNSP and Certified Ethical Hacker (CEF) certified. You can follow René on Twitter and LinkedIn.

Latest posts by René Jorissen (see all)

5 Responses to Port-channel configuration for VMWare

  • Adding the line:
    spanning-tree portfast trunk

    throws a warning on the switch

  • That’s a regular warning. It notifies you about the consequences of the command (putting the port directly in forwarding state, skipping the listening and learning states)

  • So presuming you have 8Nics in a host – 2 for Management, 2 for vMotion and 4 for VM traffic – would you create port channels for each of these 3, or just for the vmtraffic? I suppose my question is, does it make a massive difference having the Vmotion and Management as an etherchannel compared to not having them as etherchannel?

  • Hey Rich,

    You can combine Management and vMotion in the same etherchannel. The amount of management traffic is very low, so there is almost no impact on vMotion.

  • I have my cisco configured with etherchannel in trunk mode as you have explain here but I am having difficulty though I have configured ESXi 5.5 with below :
    – 2 NICs connected to cisco switch ports configured with same etherchannel no.
    – NIC teaming: load balancing set as Route based on IP Hash
    – Entered VLAN ID in Management network.

    I have additional switchport configured in access mode with windows server connected and I am trying to access esxi from this server using webclient.

    Am i missing any additional configuration

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.