Connecting the world…

virtual

HP Virtual Connect Manager

While change the configuration of within a HP Virtual Connect Manager I noticed that I didn’t have any options to delete server profiles, Ethernet Networks or Shared Uplink Sets within the web browser.

I needed to change the configuration dramatically from an active / standby configuration to an active / active configuration. I also needed to change the complete server profile configuration and Ethernet Networks configuration.

I noticed that I can also connect through SSH to the HP VC Flex-10 Enet modules. This presents a CLI with different command options. And of course I had more options within the CLI compared to the web interface.

——————————————————————————-
HP Virtual Connect Management CLI v3.18
Build: 3.18-3 (r46087) Apr  1 2011 17:45:49
(C) Copyright 2006-2011 Hewlett-Packard Development Company, L.P.
All Rights Reserved
——————————————————————————-

GETTING STARTED:

help           : displays a list of available subcommands
exit           : quits the command shell
<subcommand> ? : displays a list of managed elements for a subcommand
<subcommand> <managed element> ? : displays detailed help for a command

->?

Through the CLI I had the option to remove the server profiles, Ethernet Networks and the configured Shared Uplink Set. The help command (?) is very useful to check the command syntax to remove different configuration settings. You have to remove the different items in the correct order. I used the following order:

  1. 1. Server Profile : remove profile <profile_name>
  2. 2. Ethernet Networks : remove network <enet_name>
  3. 3 Shared Uplink Set : remove uplinkset <sus_name>

When you try to delete the items in the wrong order you will receive an error message on the console, like shown below.

->remove uplinkset SUS1
ERROR: Operation not allowed : The requested shared uplink set is currently in use by one or more networks

After deleting the configuration I configured my desired setup. The configuration can be a lit bumpy, which depends on the firmware used with the Virtual Connect Manager. I found a very good article on configuring HP Virtual Connect Manager in conjunction with ESX, Windows Hyper-V.

HP Virtual Connect Ethernet Cookbook: Single and Multiple Enclosure Domain

TIP: when configuring or changing Ethernet network settings on a Server Profile, first unassigned the profile from the bay. Changing settings on an unassigned profile is much faster than on an assigned profile.

Cisco Virtual Com

It took some time, but Cisco started to migrate from the blue RJ-45 based console cable to an USB based console cable. The latest types of routers and switches are equipped with both types of connections or only with the USB based connection, like the new IBM blade switches.

The picture below shows the console ports on a Cisco 2921 router.

28072010035Sorry for the bad quality, I guess I will never be a good paparazzi. You can see the USB and the RJ-45 connection. To use the USB connection you need to install the Cisco Virtual Com software. The software can be downloaded through the Cisco Download center, like shown below.

Cisco_USBconsole_downloadThe installation process for Windows based workstations is

VMware: upgrade VMware Tools and Virtual Hardware for Microsoft ISA array

Today I have been troubleshooting problems with a Microsoft ISA array. The array didn’t function anymore after moving the Configuration Storage Server and one array member from a VMware 3.5 environment to a VMware 4.0 environment. After moving the array member the VMware Tools were upgraded and also the Virtual Hardware was upgraded. After rebooting the moved array member the customer received multiple error messages, like duplicate IP addresses and users not able to access resource through the reverse proxy.

A Microsoft ISA array uses Network Load-Balancing and NLB was the cause of all problems. After upgrading the VMware Tools and the Virtual Hardware, NLB needs to be reconfigured. The complete configuration of NLB was lost. I reconfigured NLB (multicast with IGMP support) and the problem was resolved. The array members were functioning properly again.

Moving and upgrading the second array member resulted in the same problems with the same cause. Reconfiguring NLB on the second array member did the trick. So be careful when moving ISA array members with NLB configured from a VMware 3.5 to a VMware 4.0 environment, especially when upgrading VMware Tools and the Virtual Hardware.

Link State Tracking

Last week a friend called me and told me he was having serious problems with his network. A complete blade environment wasn’t able to communicate with the rest of the network. I asked what changed in the network and he told me that he had added a VLAN to a trunk allowed lists.

Because he is a friend, I dialed in and checked the configuration of the switch. I noticed that all ports on the switch were err-disabled. What happened here, that all switch ports were err-disabled!!! I noticed the configuration of link state tracking on all ports.

Link-state tracking, also known as trunk failover, is a feature that binds the link state of multiple interfaces. Link-state tracking provides redundancy in the network when used with server network interface card (NIC) adapter teaming. When the server network adapters are configured in a primary or secondary relationship known as teaming and the link is lost on the primary interface, connectivity transparently changes to the secondary interface.

At first I was skeptic about the link state configuration and asked my friend why it was used. He couldn’t give me any answer, because he didn’t configure the switch. For me it was hard to find a reason why link state tracking was used, because I wasn’t familiar with the network. I removed the link state configuration from the switch. All ports changed to a normal state. I noticed that the uplink (port-channel) configuration wasn’t correct. They added the VLAN to the trunk allowed lists on a member port and not on the port-channel interface.

After helping my friend and dreaming for a couple of days, I started thinking about the Link State Tracking feature. I tried to discover why someone configured the feature in my friends environment. Eventually, after some brain cracking, I found the solution. Let’s look at the following example environment.

LinkStateTracking

The figure shows one ESX server, which has two NIC’s. One NIC is connected to bl-sw01 and the other NIC is connected to bl-sw02. The ESX uses the load-balancing algorithm “Route based on Virtual PortID”.

Now lets assume the link between bl-sw02 and dis-sw02 loses its connection. Because the ESX server still has a connection with bl-sw02, it keeps sending packet that way. Switch bl-sw02 doesn’t have any uplink to the rest of the network, so the packet will get dropped.

When using Link State Tracking the connection between the ESX server and switch bl-sw02 will also loose its connection when the uplink between bl-sw02 en switch dis-sw02 gets lost. The ESX server will only use the connection with switch bl-sw01 to reach the rest of the network. Link State Tracking uses upstream and downstream interfaces. In the example the connection between the switch port, which connects switch bl-sw02 to switch dis-sw02, would be configured as an upstream port. The switch port to the ESX server would be configured as a downstream port. The downstream port is put in err-disable state when the upstream port loses its connection. This is exactly what you would like to accomplish.

The first step to enable Link State Tracking globally on the switch:

bl-sw02(config)# link state track 1

The next step is configuring the upstream and downstream interfaces.

interface GigabitEthernet0/16
description switch-uplink

switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
link state group 1 upstream
spanning-tree link-type point-to-point

!

interface GigabitEthernet0/10
description ESX01

switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
link state group 1 downstream
spanning-tree portfast trunk

You can check the status of the Link State Group with the following command:

bl-sw02#show link state group detail

Link State Group: 1 Status: Enabled, Up

Upstream Interfaces : Gi0/16(Up)

Downstream Interfaces : Gi0/10(Up)

In the future I will use Link State Tracking, especially in blade environments. At least in blade environments with multiple switch, which don’t support some kind of stacking technology, and servers with multiple NIC’s.

www.booches.nl on a Synology DS107+

I wanted to buy a new USB disc for backing up all my files, but I didn’t know what to buy. A storage consultant told me about the Synology products. Together with some colleagues, we started to look at the different products. At the end we narrowed our search to the Synology DS107+. This is a NAS with a web server based on Apache and some other nice “tools”.

I started to play a little with the web server. At first I only found the option to run one single website, but I am running more than one website. So I started to look at different forums for modifying the configuration. At the end I found an article with described the way to configure the HTTPD daemon for using virtual hosts.

I took the following steps to enable the usage of virtual hosts:

  1. Edit the file /usr/syno/apache/conf/httpd.conf-user
      – Unquote the line: Include conf/extra/httpd-vhosts.conf
  2. Create the file /usr/syno/apache/conf/extra/httpd-vhosts.conf
      NameVirtualHost *:80

      <VirtualHost *:80>
      ServerName www.booches.nl
      DirectoryIndex index.php index.html index.htm index.shtml
      DocumentRoot /volume1/websites/www
      <Directory “/volume1/websites/www”>
      AllowOverride all
      </Directory>
      </VirtualHost>

      <VirtualHost *:80>
      ServerName os3.booches.nl
      DirectoryIndex index.php index.html index.htm index.shtml
      DocumentRoot /volume1/websites/os3
      <Directory “/volume1/websites/os3”>
      AllowOverride all
      </Directory>
      </VirtualHost>

      <VirtualHost *:80>
      ServerName www.emmastraat32.nl
      DirectoryIndex index.php index.html index.htm index.shtml
      DocumentRoot /volume1/websites/emmastraat
      <Directory “/volume1/websites/emmastraat”>
      AllowOverride all
      </Directory>
      </VirtualHost>

  3. Restart the HTTPD daemon
      /usr/syno/etc/rc.d/S97apache-user.sh restart

For WordPress to work, I had to create a database in MySql. This is simple with the MySql command line queries. It has been a long time for me playing with MySql, but it was fun nevertheless (Man, I sound like a computer geek….). I create the same user credentials for the WordPress database and added them to the WordPress configuration file.

Next I re-configured the static NAT entry on my Cisco 877W router, so you all are directed to the correct inside host. Now I am wondering if the NAS works and I am especially interested in the performance of the NAS. As far as I have noticed the performance is less in comparison to my IIS web server. I give it the benefit of the doubt for the time being…..or else back to my IIS web server.